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Goals 

• Familiarize CRISM data users with the new 
MTRDR data set and products. 

• Learn how to… 
– open and browse files 
– create and analyze spectra 
– create custom visualization products 

• All material provided online as a take-home 
exercise. 
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Outline 

1. Basics 
 1. CRISM Analysis Toolkit (CAT) installation 
 2. Opening and displaying an MTRDR spectral cube 
 3. Displaying spectra 
 4. Opening and displaying an MTRDR summary parameter cube 
 5. Linking and browsing 

 2. Spectral Analysis 
 1. Selecting a region of interest (ROI) 
 2. Calculating statistics 
 3. Enhancing features 
 4. Interpretation 

3.  Visualization 
 1. Custom RGB products 
 2. 3-Dimensional views 
 3. Mosaicking   
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BASICS 
Walk-Through Section 1 
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CRISM Analysis Toolkit (CAT) 

• The CRISM Analysis Toolkit (CAT) is a series of custom 
IDL procedures packaged as a plug-in to ENVI, a 
proprietary remote sensing software available through 
ITT Exelis. 

 
• To download and install the CAT, go to 
http://pds-geosciences.wustl.edu/missions/mro/crism.htm 

 
• You will need CAT Version 7.0 or better to utilize the 

MTRDRs and related data products. 
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Opening an MTRDR cube 

• Start IDL/ENVI, with CRISM Analysis Toolkit (CAT) installed 
• On the main menu bar, go to >CAT >Open CRISM File 
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• In open file dialog 
box, select 
*IF*J_MTR3.IMG 
cube and click OK  



Initial Display of MTRDR cube 
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• Any image cube is initially opened in 
ENVI in a cluster of 3 windows. 
• Scroll (shows full spatial extent) 
• Image (full spatial resolution) 
• Zoom (4x resolution subset) 

 
• Red box in the Scroll window shows 

location of Image window; red box in 
the Image window shows location of 
Zoom window. 

 
• HINT: For CRISM images, it is usually 

helpful to maximize the Image window, 
after which the Scroll window is no 
longer needed (see next slide). 

 Scroll 

Image 

Zoom 



Default RGB Stretch for MTRDR 
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Change Zoom window 
size or magnification 
level, or turn 
crosshairs on here 

• The default bands for an MTRDR are 
• R: Band 304 (2529.51 nm) 
• G: Band 122 (1329.21 nm) 
• B: Band 41 (768.40 nm) 
 

• Equivalent to TAN browse product 
 

• All bands are listed in the Available 
Bands List and you can load any 
combination. 

 
• By default, ENVI applies a 2% Linear 

stretch to each band independently; 
a 1% Linear stretch is shown at left. 
 



Displaying a MTRDR Spectrum 
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• From the Image window menu, >Tools >Profiles >Z Profile (Spectrum) 
 

Z-profile 
extracted at 
Zoom 
window 
location. 

Colored vertical lines on spectral plot indicate RGB 
wavelength positions – can adjust, reload new 
combination in Image window. 



Adjusting the Spectral Plot 
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• Go to >Edit >Plot 
Parameters to set 
the x- and y-axis 
ranges, change 
plot labels, colors, 
etc. 

 
• HINT: Leaving 

this dialog box 
open will keep the 
axis range from 
changing as you 
browse the scene. 

 • Go to >Options >Set Z Profile Avg 
Window to change the number of 
pixels averaged together for the 
displayed spectrum. 



Anatomy of a MTRDR Spectrum 
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2-micron atmospheric 
correction residual 

Location of bad bands at detector and 
filter boundaries 

VNIR detector wavelengths 
(0.4-1µm) 

IR detector wavelengths 
(1-4 µm) 
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Opening an MTRDR Summary Parameter cube 

• Same procedure as before… On the main menu bar, go to >CAT 
>Open CRISM File 

• Choose *SU*J_MTR3.IMG file and click OK 
 

• R770 loaded by 
default 

 
• All SU bands 

(parameters) 
displayed in 
Available Bands 
List  



SU MTRDR: Single Band Display 
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• Load the D2300 parameter: from Available Bands List, right click on 
D2300 and select Load Band to New Display 

• Default Linear 2% 
stretch includes 
unrealistic parameter 
values less than zero 



SU MTRDR: Apply Appropriate Stretch 
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• For most band depth and similar measures of absorption,  
• Zero is the minimum realistic value 
• The 99th percentile is typically a good maximum, although there is 

a empirically-determined “minimum maximum” that varies by 
parameter (e.g., 0.02 for D2300) 

• From Image window, go to >Enhance >Interactive Stretching 

• Type min and max values or slide  
dashed bars until at correct percentile 
values (will display along bottom) 

 
• If needed, modify the histogram 

binning and range under >Options 
>Histogram Parameters 



SU MTRDR: D2300 Display Comparison 
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• To apply color ramp, go to >Tools 
>Color Mapping > ENVI Color Tables 

Default Stretch 
(-0.006 to 0.022) 

Optimized Stretch, 
Grayscale 

(0.0 to 0.027) 

Optimized Stretch, 
Blue-Red Color Ramp 

(0.0 to 0.027) 



SU MTRDR: RGB Display and Stretch 

• Load PHY from Available Bands 
List: >Select RGB Color >click on 
D2300, BD2210, and BD1900 to fill 
in RGB fields >New Display from 
drop-down >Load RGB 

• Optimize stretch of each band from 
Image window: >Enhance 
>Interactive Stretching 

 
PHY 
Browse 
Product 
Result: 
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D2300 
Min: 0.003 

(distribution 
peak) 

Max: 0.028 (99th 
percentile) 

BD2210 
Min: 0.001 

(distribution 
peak) 

Max: 0.020 
(“minimum 
maximum”) 

BD1900  
Min: 0.014 

(distribution 
peak) 

Max: 0.046 (99th 
percentile) 



Other Browse Products for 94F6 
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FEM 
R: BD530 
G: SH600 
B: BD11000VIS 
 

MAF 
R: OLINDEX2 
G: LCPINDEX 
B: HCPINDEX 

HYD 
R: SINDEX 
G: BD2100 
B: BD1900 



Linking Spectral and Summary Parameter Cubes 
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•  From either Image window, >Tools >Link then one of  
• >Link Displays for pixel-location based link (requires exactly same 

size images; allows blinking and transparency), -OR- 
• >Geographic Link for map projected link (can be different spatial 

coverage or resolutions) 



SPECTRAL ANALYSIS 
Walk-Through Section 2 
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Spectral Analysis Methods 

• In general, there are 3 steps to spectral analysis: 
1. Locate interesting material(s) 

- Summary parameters are a good start 

2. Collect best possible spectra (scene “endmembers”) 
- Pixel average, Region of Interest (ROI), etc. 

3. Interpret endmember spectra 
- E.g., comparison to laboratory mineral spectra 

• This is what ENVI is designed to do… 
– There are many analysis tools/options available within 

the ENVI software environment.   
– Not all of them work well with CRISM data. 
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Pixel-based Endmember Extraction (1/2) 

• As an example, let’s find an endmember spectrum for the 
D2300-bearing material in FRT000094F6. 
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Nominal Stretch 
(0.0 to 0.022) 

Emphasized Stretch 
(0.04 to 0.05) 

• Load D2300 as single band and 
stretch to emphasize highest 
realistic D2300 values. 

• Link D2300 with MTRDR 
spectral cube and PHY browse 
(optional, but useful) 

Spectral Cube 
RGB 

PHY Browse 

D2300 D2300 

link link link 



Pixel-based Endmember Extraction (2/2) 

• From the linked spectral cube Image window, extract a Z-profile (Spectrum) 
• In the spectral plot window 

– Go to >Edit >Plot Parameters to adjust y-axis (65535 values skew the range)  
– Right click anywhere to view Plot Key and set Z-profile Avg Window to 3x3 pixels 
– Preserve this spectrum for later use under >Options >New Window: with Plots… 
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Spectral Cube 
RGB 



ROI-based Endmember Extraction (1/3) 
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• Create a Region of Interest (ROI) from the 
highest D2300 values throughout the scene 

• In the spectral cube Image window, go to 
>Overlay >Region of Interest 
 
 

 

• In the ROI Tool, 
>Options >Band 
Threshold to ROI 

• Select the D2300 band 
from the SU MTRDR file 

• Type in min and max 
values of 0.04 and 
0.05, respectively 

• Should get a result of 
198 pixels 

• May want to refine 
threshold range to get 
fewer pixels 



ROI-based Endmember Extraction (2/3) 
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• The ROI appears as red pixels in the 
displayed window 

• In the ROI Tool, calculate the average of 
the pixels by clicking >Stats 
 • Right click within 

the Stats Results 
plot area to adjust 
Plot Parameters 
and view Plot Key 

• Click and drag the 
Mean spectrum to 
the previously-
created spectral 
plot containing the 
pixel-based 
endmember 
spectrum 
 

ROI pixels 
also here 



ROI-based Endmember Extraction (3/3) 

• A third method would be to define a polygon ROI… 
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• In the ROI Tool, select >ROI_Type >Polygon 
• Create New Region and select Zoom as the 

active window 
 • Calculate statistics on the 

polygon-ROI as before 
• The polygon ROI can be used 

alone or (e.g.) to spatially 
constrain the band threshold 
ROI:  >ROI Tool > Options  
            >Intersect  

      Regions 

right click 
to finalize 



Example Endmember Spectra – D2300 

• Four D2300 spectra were extracted using the methods discussed in 
previous slides: 1) 3x3 pixel average, 2) band threshold, 3) polygon, 
and 4) band threshold-polygon intersection. 
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• In this scene, 
there are no 
huge 
differences 
between the 
spectra. 

• In general, 
more pixels = 
less spectral 
noise. 
 



Enhancing Spectral Features 

• There are two widely accepted ways to enhance spectral 
features to aid with interpretation: 
– Ratio to a spectrally neutral area in the same scene 
– Continuum removal 

• Benefit to using a ratio is that you may cancel out detector noise 
or spikes  

• However, if your denominator spectrum is not truly neutral  you 
may introduce unintended spectral shape, e.g., from: 
– Broad features from mafics like olivine or pyroxene 
– Spectral slope 
– VNIR variability from ferric oxide-related features 

• Continuum removal is not recommended over the entire CRISM 
wavelength range, either 
– Best results when focused on relatively narrow range bracketing the 

feature(s) of interest  
27 



Ratioing (1/2) 
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• Numerator: let’s use the D2300 spectrum with the least noise 
- the average from the green polygon ROI. 

• Denominator: Create a similar-sized polygon in the nearby 
spectrally bland dark material and calculate its average 
spectrum 
 

Numerator 

Denominator 

• From the ENVI main 
menu, go to >Basic 
Tools > Spectral Math 
• Enter the 

expression: s1/s2 
• Map the 

numerator (s1) 
and denominator 
(s2) to the 
Available Spectra 
List 

• Output to New 
Window 



Ratioing (2/2) 
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Ratio-Enhanced 

Original D2300 Spectrum Numerator 

Denominator 



Continuum Removal (1/2) 

• Examine 3 wavelength regions independently: ~1.4, ~1.9, and ~2.3 µm. 
• In >Edit >Plot Parameters, subset the x-axis range to bracket the feature 

of interest 
• Then choose Plot_Function > Continuum Removed as the display method 
• You will likely have to rescale the y-axis in the continuum removed-plot 
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The 1.4 band is better-emphasized by the ratio! 
Normal Continuum Removed 

1.427µm ? 



Continuum Removal (2/2) 

31 

Normal Continuum Removed 

2.291   2.390µm 

1.921µm 



Spectral Libraries 

• Save spectra as ENVI spectral libraries 
(*.sli), or export as ASCII text file 
– From a spectral plot window, >File >Save Plot As 

> Spectral Library 
– HINT: Line colors are not preserved; make sure 

you rename the spectra appropriately 
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• To retrieve a saved library or view 
a reference spectral library 
– From the ENVI main menu, 

>Spectral > Spectral Libraries 
> Spectral Library Viewer 

– Select *.sli file, or open new 
• CRISM spectral library: 

http://geo.pds.nasa.gov/missions/
mro/spectral_library.htm 
 



Interpretation 

• Compare the enhanced spectra to laboratory reference 
spectra to locate the best mineralogic match(es). 

• For the D2300 endmember example, open a library 
containing phyllosilicate spectra and load candidate 
reference spectra to examine absorption band positions 
in detail… 
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Diagnostic bands 
match best with 
nontronite. 1.427     1.941 

2.291  2.390  



Interpretation Guidelines 

• Common sense rules apply to spectral interpretation: 
– All major absorption features in the spectrum of the proposed 

reference mineral should be present or otherwise accounted for 
– Relative strengths and shapes of spectral features of the 

proposed reference mineral should be replicated in the CRISM 
spectrum 

• Even a single CRISM pixel (~20m) is unlikely to comprise 
a single pure mineral, i.e.,  
– Spatial mixing is likely 
– Intimate mixtures can also occur 
– Geochemically intermediate phases are also possible 

• So, simple explanations are usually best, but complexity 
happens.  It’s real geology, after all! 
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VISUALIZATION 
Walk-Through Section 3 
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Custom Composites 

• Custom RGB composites 
and browse products can 
take advantage the 
joined nature of the 
MTRDR summary 
parameter cube. 

 
• Example at right  
 shows ferric,  
 ferrous, and  
 clay variability. 
• MANY color units 
 to follow-up on!! 
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R: BD530  G: OLINDEX2  B:D2300 



3-D Rendering (1/3) 

• 3-D visualization can be helpful for understanding 
relationships between different units. 

• First, open the map projected DDR cube (*DE*L_MTR1.IMG) 
and load the Elevation band 
– Highest resolution MOLA gridded data is oversampled to match 

CRISM spatial scale; co-registration is good but interpolation in 
sparse areas can lead to feature mismatch 

– Note the approximate elevation range 
    under >Enhance >Interactive Stretching 
 (you’ll need this later) 
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• Load and stretch the band or RGB 
composite that you want to view in 3D 

• From the Image window, go to 
>Tools >3D Surface View 

 



3-D Rendering (2/3) 

• In the 3D SurfaceView Input dialog 
– Indicate Full DEM Resolution 
– Type in min and max elevation values 

that bracket the actual range  
– Indicate Full Image Resolution 
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Initial 
3D view 



3-D Rendering (3/3) 

• Use mouse buttons to navigate, or 
use >Options >Surface Controls 

• Perspective view here is looking 
south (5x vertical exaggeration) 

• Note that the lowest point for the 
western crater (right side, arrows) 
is offset from the crater’s center 
due to sparseness of the 
interpolated MOLA tracks 
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Colorized topography  
20m contours 

PHY browse product 

TAN browse product 



Mosaicking (1/4) 

• Mosaicking multiple CRISM cubes together allows broader 
geographic context for inferred mineralogy. 
– Can mosaic map-projected spectral, summary parameter, or DDR cubes 

• MTRDR empirical correction of scene-specific geometric 
dependencies greatly improves mosaicking results.  
 

 
• Open the MTRDR files: 

– FRT000094F6 
– FRT00021BCB 

• From the ENVI main menu, go to  
 >Map >Mosaicking >Georeferenced 
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Mosaicking (2/4) 

• In the Mosaic dialog box, go to >Import 
>Import Files and Edit Properties 
– Select the two cubes you wish to mosaic 
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• For each file, 
indicate a Data 
Ignore Value of 
65535 and Mosaic 
Display of Gray 
Scale, Band 1 (you 
can change this 
later). 



Mosaicking (3/4) 

• You should see the indicated band 
(1: R770) appear in the mosaic 
window for each cube. 

• To save, go to >File >Apply 
– Indicate filename and 
 include a  
 background  
 value of 65535. 
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To adjust layering order or edit display 
properties, right click on filename here 



Mosaicking (4/4) 
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• Load a mosaic just like 
any other file 

• Go to >File >Edit ENVI 
Header to set Data 
Ignore Value (65535) 
and reapply band 
names if desired 

• TAN browse product at 
right  
• No histogram 

matching  
• Some seams 

visible, and a few 
pixel offset on 
slopes where the 
MOLA shape model 
is perhaps 
inadequate R: R2529    G: IRA    B:R770 



More Mosaic Results 

• PHY browse 
product  

• Some parameters 
mosaic better than 
others due to the 
nature of their 
formulation 
– More noise is 

apparent in 
FRT00021BCB 
(right image) as a 
result of the 125K 
detector 
temperature  
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R: D2300  G: BD2210  B:BD1900 



QUESTIONS? 

Please also visit the PDS forum: 
http://geoweb.rsl.wustl.edu/community/index.php?/ 

forum/20-mrocrism-data-users-workshop-2012/ 
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